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Exercise 1 : Hello World
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Start Rhapsody in C++

$ cd ~/Rhapsody753

$ ./RhapsodyInC++
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Creating a Project

 New from File menu



5

Select the working directory
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Browser

 The browser shows you everything that is in the model.

 Note that Rational Rhapsody creates an Object Model 
Diagram (OMD).

Browser

Object

model

diagram
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Drawing a class

 In this Object Model Diagram, click the Class icon      
to draw a class named Display.

Expand the 

browser to see 

that the class 

Display also 

appears in the 

browser.

Show/Hide Drawing 

Toolbar
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Remove from View / Delete from model

 Two ways of deleting a class
Remove the class from the view 

(this is what the Delete key does).

Delete the class from the model.

 If you use the delete key or 
select Remove from View, 
then the class Display is just 
removed from this diagram, 
but remains in the browser.

 If you select Delete from 
Model, then you must confirm 
with Yes in order to remove 
the class from the entire model.
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Adding a constructor

 The simplest way to add a 
constructor is to right-click on 
the class and choose       
Add New > Constructor.

 You do not need any 
constructor arguments;    
click OK.

Constructors may also be 
added through the 
featuresOperations tab. 
Click New and select 
Constructor.
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Display options

 You would expect to see the 
constructor shown on the class 
on the Object Model Diagram.

 You can control what gets 
displayed on this view of the 
class by using Display Options.

 Right-click Display class and 
select Display Options.

Set the options to display All
attributes and All operations.
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Display constructor

You should be able to see the constructor is now 
shown in both the browser and the OMD (object 
model diagram).

Constructor
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Adding an implementation

 Select the Display constructor in the browser and 
double-click to open the features window.

 Select the Implementation tab and enter the 
following:

cout << “Hello World” << endl;

If you are not using Visual C++ 

6.0, then you should add the 

std namespace, for example, 
std::cout << “Hello 

World” << std::endl;

Or, set the property 

CPP_CG::Class::Implementati
onProlog to using 

namespace std;.
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Adding an implementation

 Display class를더블클릭하고 Properties 탭을
선택한후 View All로바꿈

If you are not using Visual C++ 6.0, then you should add the std namespace, for example, 
std::cout << “Hello World” << std::endl; Or, set the property 

CPP_CG::Class::ImplementationProlog to using namespace std;.
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 CPP_CG의 Class 항목에서 ImplementationProlog에
아래와같이입력
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Adding an implementation

앞의과정이번거로울경우 Ubuntu에서는아래와
같이입력

또는아래와같이입력해도가능. Ubuntu에서는
#include <stdio.h> 가없어도컴파일이됨

std::cout << “Hello World” << std::endl;

printf(“Hello World\n\r”);
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#include <iostream>

Since you have used cout, 
you must add an include 
of the iostream header to 
the Display class.

 In the browser, select the 
Display class and double-
click to bring up the 
features.
Select the Properties tab

Ensure that the Common 
View is selected

Enter <iostream> into the 
“ImpIncludes” property.

ImpIncludes is an abbreviation for Implementation Includes.
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Renaming a component

 In order to generate code, you must first create a 
component.

 Expand the components in the browser and rename 
the existing component called DefaultComponent to 
Test. Also name the Directory to Test.

Executable
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Test component

Now expand Configurations and rename the 
DefaultConfig to Release.
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Initial instance

 Select the 
Initialization tab, 
expand the Default 
package, and select 
the Display class.

 The main will create an 
initial instance of the 
Display class.
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Settings

 You need to select an 
environment so that 
Rational Rhapsody 
knows how to create 
an appropriate 
Makefile.

 Select the Settings tab.

 Select the appropriate 
environment, for 
example: Linux.

You will learn about the 

many other settings later.
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Renaming the OMD

 Expand the Object Model Diagrams in the browser. 
Right-click the Object Model Diagram Model1 to 
invoke the features dialog.

 Rename the diagram from Model1 to Overview.
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Generating code

 You are now ready to generate code.

Save the model. 

Select Generate/Make/Run.

Click Yes to the question:
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Handling errors

 If there are errors during the compilation, double-click 
the relevant line to find out where the error occurred.
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Hello World

 You should see the following:

 Before continuing, make sure you stop the 
executable by one of the following methods:

Closing the console window. 

Using the Stop Make / Execution button.

Ctrl+Break.
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Generated files

 The generated files are located in the following 
directory:

Display class

Main

Executable

Makefile
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Editing the code

 You can edit the generated files 
from within Rational Rhapsody.

 Select the Display class, right-click, 
and select Edit Code.

 Both the implementation (.cpp ) and 
specification (.h ) are shown in 
tabbed windows.
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Modifying the code
 You can modify the generated code.

 In the Display.cpp file, change the implementation to 
print out Constructed instead of Hello World.

 Transfer the focus back to another window to 
roundtrip the modifications back into the model.

 Note that the model has been updated automatically.

 In general, the roundtripping works very well, but 

beware not everything can be roundtripped.
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Displaying the Main and Make

 The Main and Makefile can be displayed by simply 
double-clicking the hyperlinks:
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Project files

Generated code

AutoSave

The model

Project workspace
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Extended exercise

 You can customize Rational 
Rhapsody to get quick access to the 
location of the current project.

 Select Tools > Customize. 



31

Customize

 Click      to enter a new entry 
Explore to the Tools menu.

 Set the Command to 
explorer.

 Set Arguments to .

 Click OK.

 Select Tools > Explore.
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Exercise 2: Count down
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Copying a project

Select File > Save As.

Press     to select the upper folder.

Press     to create a new folder.

Rename New Folder to 
CountDown.

Select the new folder CountDown.

Save the project as 
CountDown.rpy.

The new CountDown project is 
opened in Rational Rhapsody with 
the previous workspace preserved.

Each time there is an auto-save, Rational 

Rhapsody only saves just what has changed 

since the last auto-save. 
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Loading a project

 Choose one of the following ways to open a project:  

Start Rational Rhapsody and select File > Open.

Or double-click on the file.

Or start Rational Rhapsody and drag the file                           
into Rational Rhapsody.

Or use Open Project in the Welcome screen.      

The Rhapsody.ini file determines which Rational Rhapsody (C / C++ / J / Ada) 

will be opened on double-clicking the .rpy file.
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Adding an attribute

 To add an attribute, double-click on the Display class 
to bring up the features and select the Attributes tab.

 Click New to add an attribute count of type int.

 Set the initial value to 0.
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Generated code for an attribute

Click Save then edit the code for 
the Display class so you can examine 
the code.

Accessor

Mutator

Initial Value

Protected attribute
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What are accessors and mutators?

 By default, all attribute data members in Rational 
Rhapsody are protected.

 If other classes need access to these attributes, then 
they must use an Accessor, for example, getCount() 
or Mutator, for example, setCount().

 This allows the designer of a class, the freedom to 
change the type of an attribute without having to alert 
all users of the class. The designer would just need to 
modify the accessor and mutator. 

 In most cases, attributes do not need accessors or 
mutators; you will see later how to stop them being 
generated.
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Attribute visibility

 Changing the Visibility in the Attribute features dialog 
changes the mutator and accessor visibility (not the 
data member visibility).



39

Adding an operation

Using the features for the Display class, select the 
Operations tab > Primitive Operation.

Add a new primitive operation called print.
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Arguments

 Double-click Print to open the features for the print 
operation.

 Select the Arguments tab.

 Add an argument n of type int.
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Adding implementation

Select the Implementation tab for the print operation 
and add:

cout << “Count = “ << n << endl;
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Another print operation

 In a similar way, add another operation called print, 
this time with an argument s of type char* and with 
implementation:

cout << s << endl;

Set the argument type before setting the name. 

This avoids a conflict where the two print 

operations have identical signatures.
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Operation isDone()

Add another operation called isDone that returns a 
bool and has the following implementation:

return (0==count);

By typing 0==count instead of 

count==0, enables the compiler to 

detect the common error of where = 

is typed instead of ==.
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Active Code View

 Select View > Active Code View.     

 The active code view is context 
sensitive and is automatically updated 
as the model is changed. The window 
also changes dynamically to show the 
generated code for the highlighted 
model element.

Note that although leaving the active 

code view always open is useful, it 

does slow down model manipulation 

since the code will get regenerated 

anytime any model element gets 

modified.
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Using the print operation

 In the Active Code View, 
change the code for the 
constructor to use the print
operation.

Make sure you have selected 
the Implementation.

 Change the focus to another window such as the 
browser and check that this modification has been 
automatically round-tripped.

 Save the changes.

 Generate / Make / Run.
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Adding a statechart

 You would like to get the Display class to count down 
from 10 to 0 in intervals of 200ms.

 To do this, you need to give some behavior to the 
class. You can do this by adding a statechart.

 Right-Click the Display class and select Add New > 
Statechart.
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Draw a simple statechart

Action

Trigger

Guard

Transition

State

Default

transition



48

Transitions

 Once a transition has been drawn, there are two ways 
in which to enter information:

In text format - example: [isDone()]/print(“Done”);

By the features of the transition (activated by double-
clicking or right-clicking on the transition).

An empty line forces the action 

to appear on a new line.

Ctrl+Enter closes 

the entry field.
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Timer mechanism

 A timer is provided that can be used within the 
statecharts.

 tm(200) acts as an event that will be taken 200ms 
after the state has been entered.

 When entering into the state, the timer will be started.

 When exiting from the state, the timer will be stopped.

The timer uses the 

OS Tick and only 

generates timeouts 

that are a multiple 

of ticks.
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Timeouts

 If you have a system tick of say 20ms and you ask 
for a timeout of 65ms, then the resulting timeout will 
actually be between 80ms and 100ms, depending 
on when the timeout is started relative to the 
system tick.

System tick

20ms

80ms ≤ Timeout ≤ 100ms

Start timeout End timeout

time

If precise timeouts are required, then it is recommended you 

use a hardware timer in combination with triggered operations.
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Counting down

 Save     

 Generate / Make / Run

Do NOT forget to close this window, before 

doing another Generate / Make / Run.

Constructor

Default Transition
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 Now that the Display class is Reactive

A reactive class is one that reacts to receiving events or 
timeouts.

Identified by symbol in the browser       and the OMD.

 Also note that the Statechart appears in the browser.

Statechart symbol



53

Use the Active Code View to examine the generated 
code for the Display class.

Generated code: display.h

Framework includes

Framework class

Thread on 

which to wait

Note that the Display class inherits from OMReactive, which is 

one of the framework base classes. This is a class that simply 

waits for timeouts or events. When it receives a timeout or an 

event, it calls the rootState_processEvent() operation.
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Generated code: display.cpp

 Display::Display(IOxfActive*  theActiveContext)
The constructor needs to know on which thread to wait.

 Display::initStatechart()
Called by the constructor to initialize the attributes used to 

manage the Statechart.

 Display::startBehavior()
Kicks off the behavior of the Statechart, invokes the 

rootState_entDef() via OXF calling 
OMReactive::startBehavior().                                               
Typically invoked from outside after construction completed.

 Display::rootState_entDef()
Called by OMReactive::startBehavior() to take the initial 

default transition.

 Display::rootState_processEvent()
Called though OXF operation OMReactive::processEvent() 

whenever the object receives an event or timeout.
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 Change the statechart implementation

Select the features for the configuration 
Release.

Select the Settings tab and set Statechart 
Implementation from Flat to Reusable.

Save / Generate / Examine code.

 The Rational Rhapsody framework allows two 
ways of implementing statecharts:

Reusable is based on the state design pattern where each state is an 
object.

 Results in faster execution and if a lot of statecharts are inherited, 
can result in smaller code.

Flat uses a switch statement.

 Results in less code that is easier to read, but is slower.

Statechart implementation
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Extended exercise

 Experiment with the line shape of transitions.
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Design level debugging

 Up to now, you have generated code and executed it, 
hoping that it works. However, as the model gets 
more and more complicated you need to validate the 
model.

 From now on, you are going to validate the model by 
doing design level debugging, this is known as 
Animation.
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Animation

 Create a configuration by 
copying the Release
configuration:

Press Ctrl and drag the 
Release configuration onto 
the Configurations folder.

Rename the new 
configuration Debug.

 Set the Instrumentation 
Mode to Animation.
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Multiple configurations

 Now that you have more than one configuration, you 
must select which one you want to use.

 There are two methods:

Right-click the configuration 
and select 
Set as Active Configuration.

Select the configuration 
using the pull-down box.
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Animating

Make sure the active configuration is Debug before 
doing Save     then Generate / Make / Run.

Run will cause the Animation toolbar to be displayed.
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Animation Toolbar

 Automatically appears when an executable model is run and 
instrumentation is set to Animation.

To display or hide during animation session, select View > Toolbars > 
Animation.

 For detailed button information, select Help > Help Topics 
and search on animation toolbar.

For example, grayed out (disabled) Thread button indicates single-
threaded application.
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Starting the animation

 Click the Go Step     button.    

Note that the Display() constructor appears in the Call 
Stack.

 Continue to Go Step     until the Executable is Idle
message appears in the Animation window.
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Class Instance

Browser contains an instance of the Display class.

Right-click the instance and select Features.

Note that the attribute count has been initialized to 10.
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Statechart Instance

 Right-click the instance and select Open Instance 
Statechart.

Highlighted state indicates the 
current state of the model.

 If you do not see a highlighted 

state, you may be looking at the 

statechart of the class (design) 

rather than the statechart of the 

instance (runtime).

Default transition has also been 
triggered.

 Started will have been 

printed to the display.
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Go Idle / Go

Click Go Idle to advance to next timeout.
The executed transition chain in statechart is highlighted.

 Value for count is 
printed to display.

 Condition is 
checked for
is done.

 Not done so value 
of count is 
decremented.

Click Go and 
watch the animation 
until the instance is 
destroyed.

Exit the animation.



66

Destructor

 Add a Destructor      to the Display class.

 Add implementation  print (“Destroyed”);

 Save      then Generate / Make / Run.

Make sure you enter the code 

into the Implementation and not 

the Description field.
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Sequence diagrams

 From the browser, create a new sequence diagram 
called execution.

This sequence diagram will be used to capture what 
happens in execution.

Operation Mode will be discussed later but for this example, 
it does not matter if Analysis or Design is selected.
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Adding instances

 Add a System Border to the sequence diagram.

 Drag the Display class from the browser onto the sequence 
diagram.
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Drawing a sequence diagram

Normally, you would describe an actual scenario 
similar to this one here, however in this case, you are 
more interested in capturing what actually happens.

For the purpose of 

this training, you only 

need the system 

border and the 

Display instance line. 

There is no need to 

add any operations.
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Animated sequence diagrams

 Start the animation and click
Go.

 If a sequence diagram is open, 
then Rational Rhapsody 
creates a new animated 
sequence diagram based on 
the execution.

Note that the animated sequence 
diagram captures operations, 
timeouts, and states.
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Extended exercise I

 Rational Rhapsody can 
display the return value on 
animated sequence 
diagrams. To do so, you 
must use a macro 
OM_RETURN.

 In the implementation of the 
operation isDone(), replace 
return with OM_RETURN.
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Extended exercise II

 Try adding an extra state pausing. Then you will 
see the instance changing states.
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Properties

 There are many properties that allow customization of 
the tool and the generated code.

 Properties can be set once and for all by modifying 
the site.prp file in the Rhapsody\7.5\Share\Properties 
directory.

 The factory.prp and factoryC++.prp files contain all 
the Rational Rhapsody properties.

It is recommended you modify the 

site.prp or siteC++.prp files rather than 

the factory.prp and factoryC++.prp files. 

To do so, it is easiest to copy and paste 

from these files into the site.prp or 

siteC++.prp file.
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Properties hierarchy

If a stereotype is 

applied to an 

element, a property 

is assigned to that 

stereotype takes 

precedence over the 

element’s property.

factory.prp

site.prpproject

configuration

package

class

operation/attribute/
relation/type/…

component

factoryC++.prp

SiteC++.prp

profile
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Project properties

Bring up the Features for the CountDown project and 
select the Properties tab.



76

Properties view

 There are a very large number of properties which can 
be used to customize the tool and the generated code. 

 In order to facilitate access to these properties, there 
are several views that can be applied to the properties.

 For this training course, you use the most common 
properties which can be seen using the Common view.

It is relatively easy to 

modify the list of 

properties that can be 

seen in the Common 

view.
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Properties views

 There are several useful views of the Properties:

A user defined list of the most 

commonly accessed 

properties

Properties that have been 

overridden for the currently 

selected element & any 

‘parent’ overrides

Only properties that have 

been overridden for the 

currently selected element

Properties filtered by 

some keyword
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Useful property

 One useful property is 
General:Graphics:MaintainWindowContent.

 Setting this property means that if the size of the 
window is changed, then the view of the contents 
changes proportionally.

 Set this property.

Once a property has been 

modified it is highlighted. To 

restore the default, right-click 

on the property and select 

Un-override.

Note also the description is 

displayed for the selected 

property.
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Overridden properties

 Select View Overridden.

This shows just the 

properties that have been 

modified.
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General:graphics:MaintainWindowContent

Once this property has been set, changing the size of 
a window should keep the same view:

You need to close any open windows and then 

reopen them after setting this property.
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Accessors and mutators

 If accessors and mutators
are not needed for 
attributes, then properties 
can be set to stop their 
generation.

 Set these two properties 
so that ALL attributes in 
the project will have 
neither an accessor nor a 
mutator.
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Overridden properties

 For the attribute count, you want an accessor.

 Selecting the overridden filter shows that the 
AccessorGenerate and MutatorGenerate properties 
have been overridden higher up in the property 
hierarchy.

 Select the count attribute and override the property: 
AccessorGenerate.
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Locally overridden properties

 Select the View Locally Overridden filter to show 
that just the AccessorGenerate property has been set 
locally.

 Generate code and check that there is just an 

accessor for the attribute count.
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Property filter

A customized view of the 
properties can be created by 
using the Filter view for example:
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Extended exercise

 Experiment with some of the properties such as:

CG:CGGeneral:GeneratedCodeInBrowser

 You must regenerate the code after setting this 
property.
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Formatting individual items

 Line Colors, Fill Colors, Fonts, etc of 
selected element(s) can all be 
formatted by right clicking and selecting 
Format.
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Advanced drawing capabilities

 These advanced drawing capabilities are common to 
most diagrams:

Turn grid on/off

Snap to grid

Show rulers
Make item 

same size

Align items to 

common edge

Give items same 

spacing size

Stamp mode -

use when drawing 

same items 

repeatedly
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Aligning items to common edge

A pivot selection mechanism is used for aligning, 
sizing and spacing:

2. Select the pivot class by holding Ctrl and selecting1. Select by area

3. Choosing 

align left, 

aligns all 

classes to  

the class 

(“class_4”)
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Site.prp / SiteC++.prp

 Adding new environments is done via the file 
siteC++.prp.

 Each organization or team may want to always set 
certain properties for all of their Rational Rhapsody 
projects. To do this, set these properties for every 
Rational Rhapsody project by putting them into the 
file site.prp .

 These files can be found in the \Share\Properties 
directory.



90

Exercise 2A: Count down with LCD Display

 First, try to run the Count down application 
on the embedded target as it is.

 Then, include the code accessing LCD 
display.

 You need to prepare the hardware interface 
code. Then, combine it with the model code.

 Model code + legacy code
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New Configuration

 Right click Configurations and Add New 
Configurations

 Change the name to MontaVista

 Right click and Set as Active Configurations
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Open Feature Window for MontaVista Configuration

 Environment: MontaVista
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Initial instances 

 Check Display
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Build

 Generate 
Configuration Main 
and Make files

 Generate 
Configuration

 Build Configuration

 Check no error
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 Copy executable file to ~/nfsroot folder
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cd command with a  long path name

 Move the mouse cursor to the menu bar

 Select Location from Go menu
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cd command with a  long path name

 Copy and paste to the Terminal window
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Run on the target
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Run on the target with animation

 Change to Animation, build, and copy
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Run on the target with animation
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Copy and modify lcd1602_test.c(1)

#include <fcntl.h>

#include <stdio.h>

#include <stdlib.h>

#include <unistd.h>

#include <sys/types.h>

#include <sys/stat.h>

#include <string.h>

int fd;  

void initLCD(void)

{

fd=open("/dev/lcd1602",O_RDWR);

if (fd < 0) {

printf("Device open error : %s\n","/dev/lcd1602");

exit(1);

}   

}
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Copy and modify lcd1602_test.c(2)

void displayLCD(int count)

{

char wbuf[30];

wbuf[0] = count / 10 + 0x30;

wbuf[1] = count % 10 + 0x30;     

for (int i=2;i<15;i++) wbuf[i]=' ';

wbuf[15] = 0x0;

write(fd, wbuf, strlen(wbuf));

}
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Add Hardware Interface Code

 Right Click Test 
Component and Select 
Add New “File”
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 Double click a new file and change Name to “lcd1602” 
and Type to Implementation
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 Double click lcd1602.cpp and select the tab 
“Elements”.

 Then click New Text Element button
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 Open the text editor
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 Paste the code and click OK
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이미입력된파일을수정할경우:Open the text editor
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Open the driver
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Call Interface Routine
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Include extern (function prototype)

 Open Display class Feature window and select 
Properties
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Load the driver and run on the target
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Exercise 3: Stopwatch Project
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Create a new project
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 Right click Packages and Add New Package

 Change the name to StopwatchPkg
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 Right click StopwatchPkg and Add New-Diagrams-
Object Model Diagram

 Change the name to StopwatchOMD
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 Select Object in Diagram Tools

 Draw three objects, Button, Timer, Display
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 Select Link in Diagram Tools and draw links
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 Double click the link between Button and Timer

 Click Association change button
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 Change Both Ends to End itsTimer
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 Right click the link and change Display options
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 Repeat the same for the link between Timer and 
Display
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 Select Button object and right click

 Add New-Statechart
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 Select State and draw states.
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 Select Transition and draw

 Double click the transition

 Type in Trigger: evPress

 Type in Action: Timer.GEN(evStartStop);
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 Complete the statechart
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 Doble click Display object and open Feature window

 Select Operations Tab and press New

 Select Primitive Operations and name print
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 Double click print operation

 Select Arguments Tab and add arguments: min, sec.

 Select Implementation and type in code
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 Double click Timer object

 Select Attributes Tab

 Add attributes(seconds, minutes)
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 Add operations(print, tick, reset) in Timer object
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 Double click print operation

 Add Implementations
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 Double click tick operation

 Add Implementations
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Timer attributes

 Double click reset operation

 Add Implementations
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Statechart in Timer

 Right click Timer and Add New-Statechart
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Object Model Diagram

 Stopwatch OMD
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Generate and build

 Change component and 
configuration names

 Generate and build
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138



139
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 Right click and Generate Event
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 Generate evPress and evRelease within 3 seconds
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Exercise 4: Button Project

 Run the ButtonProject on the target with 
or without animation.
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Object Model Diagram 

 Object Model Diagram in ButtonProject
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 Statechart in Button
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 External function prototypes
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 Statechart in Led
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 External function prototypes



148

 Interface.cpp
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Interface.cpp(1)



150

Interface.cpp(2)
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 Statechart in PushSwitch



152

 External function prototypes



153

Exercise 5: Stopwatch with real displays and switches

 Modify the StopwatchProject to use LCD 
displays and button switch on the target


